Here we go again,

A brand new Development Series, but his time where we all contribute to the development of the game.

AND THAT GAME IS “HUNCHBACK”

So, this is basically to set up the development environment for the Raspberry Pi to develop the Python version of hunchback, the reason for this is to imagine we are a modern day bedroom programmer and using modern BASIC like programming language, and the language been taught is Python.

Also, this video has a surprise…. and you will see

Important URLs and commands:
PiMyLifeUp : https://pimylifeup.com/raspberry-pi-visual-studio-code/
Kick Assembler : http://theweb.dk/KickAssembler/
MagPi Books : www.magpi.cc

Vice Prerequisites Command :
sudo apt-get install build-essential byacc texi2html flex libreadline-dev libxaw7-dev texinfo libxaw7-dev libgtk2.0-cil-dev libgtkglext1-dev libpulse-dev

VICE 3.1 Source : https://sourceforge.net/projects/vice-emu/files/releases/vice-3.1.tar.gz/download

VICE Compile Commands :
tar -zxvf vice-3.1.tar.gz
cd vice-3.1

./configure -enable-fullscreen -with-pulse -with-x -enable-gnomeui
make
sudo make install
sudo cp -vR ~/Downloads/vice-3.1/data/* /usr/local/lib/vice

4 Comments

  1. Stuart on July 3, 2020 at 1:45 pm

    John – you have links to existing games where if someone is following this from scratch (Me) there are no games or subfolder in documents called share!!!



  2. Anonymous on July 3, 2020 at 2:02 pm

    John – You have an error with this command
    ./configure –enable-fullscreen –with-pulse –with-x –enable-gnomeui

    it needs to be –enable – not a single – (it’s changed it to a single long – symbol) – you will need to check the rest



  3. Stuart on July 3, 2020 at 2:10 pm

    John -This process will NOT work with winvice 3.4 – it’s different



  4. John Dale on July 10, 2020 at 8:35 am

    Hi, yes VICE 3.4 is different, they changed some things and I think 3.4 needs to have a little work on it, so thats why i used 3.1 instead.



Leave a Comment